#!/usr/bin/make -f
# Copyright © 2019 Collabora Ltd.
# SPDX-License-Identifier: MIT
# (see debian/copyright)

export LC_ALL=C.UTF-8

include /usr/share/dpkg/default.mk

%:
	dh $@

# We open-code the Meson clean, configure, build, test, install steps
# because the debhelper in SteamRT 1 'scout' is too old to have built-in
# knowledge of Meson.

override_dh_auto_clean:
	rm -fr builddir

override_dh_auto_configure:
	meson builddir \
		--prefix=/usr \
		--libexecdir=/usr/libexec \
		-Dintrospection=false \
		$(NULL)

override_dh_auto_build:
	ninja -C builddir

override_dh_auto_test:
	meson test -C builddir --verbose

override_dh_auto_install:
	DESTDIR=$(CURDIR)/debian/tmp ninja -C builddir install

override_dh_missing:
	dh_missing --fail-missing