steam-runtime-tools (0.20191204.0-0+steamrt1.1) UNRELEASED; urgency=medium

  * ...

 -- Simon McVittie <smcv@collabora.com>  Wed, 04 Dec 2019 11:22:29 +0000

steam-runtime-tools (0.20191120.0-0+steamrt1.1) scout; urgency=medium

  [ Jeremy Whiting ]
  * Check whether GLX drivers can actually draw to an X11 window.
    This provides a more thorough test than wflinfo.
  * Check whether Vulkan drivers can actually draw to an X11 window.
    This provides a more thorough test than vulkaninfo.
  * Fix reporting of timeouts in JSON

  [ Simon McVittie ]
  * Build selected executables with a RPATH.
    This allows a copy of steam-runtime-system-info bundled in the
    LD_LIBRARY_PATH Steam Runtime to find the copies of
    libsteam-runtime-tools and libjson-glib in the same Runtime.
  * Look for wflinfo, vulkaninfo and libraries adjacent to
    libsteam-runtime-tools
  * Use g++-4.8 if default g++ is older
  * Build shaders using glslangValidator
  * Fix many compiler warnings
  * check-vulkan: Add basic command-line parsing with --help
  * Add --version argument to most executables
  * check-vulkan: Optionally make the window visible
  * Look for -check-vulkan in default helpers path, not in PATH
  * check-vulkan: Look for shaders in the correct place when installed
  * Add build-dependencies for check-gl

  [ Ludovico de Nittis ]
  * Add support for libraries with hidden dependencies
  * Detect GLX and EGL graphics library vendor (either GLVND,
    legacy non-GLVND Mesa, legacy non-GLVND NVIDIA, or other non-GLVND)

 -- Simon McVittie <smcv@collabora.com>  Wed, 20 Nov 2019 14:44:45 +0000

steam-runtime-tools (0.20191024.0-0+steamrt1.1) scout; urgency=medium

  [ Ludovico de Nittis ]
  * Fix gtk-doc warnings about missing parameters
  * Add runtime content check for "overrides" and pinned libraries

  [ Simon McVittie ]
  * COPYING: Remove obsolete reference to GPL code, which was removed
    a while ago

 -- Simon McVittie <smcv@collabora.com>  Thu, 24 Oct 2019 16:05:21 +0100

steam-runtime-tools (0.20190926.1-0+steamrt1.1) scout; urgency=medium

  * tests: Replace SRT_TEST_ICD_SYSROOT with SRT_TEST_SYSROOT
  * Add minimal OS information from os-release(5)
  * Add support for ID_LIKE os-release(5) field
  * runtime: Use os-release(5) to detect Steam Runtime container/chroot

 -- Simon McVittie <smcv@collabora.com>  Thu, 26 Sep 2019 15:52:32 +0100

steam-runtime-tools (0.20190926.0-0+steamrt1.2) scout; urgency=medium

  * d/control: Add missing -dev dependency on libjson-glib-dev

 -- Simon McVittie <smcv@collabora.com>  Thu, 26 Sep 2019 14:51:55 +0100

steam-runtime-tools (0.20190926.0-0+steamrt1.1) scout; urgency=medium

  [ Ludovico de Nittis ]
  * locale: fix leaked SrtLocale

  [ Simon McVittie ]
  * graphics, library: Capture stderr from the checks
    and include it in their JSON output
  * locale: Check for the necessary files to generate more locales.
    This issue flag is known to appear on Arch Linux and its derivatives,
    which don't normally install /usr/share/i18n/SUPPORTED.
  * Generate autocleanup functions if GLib (or libglnx) supports it.
    This is not directly useful in steam-runtime-tools because we only
    require an older GLib, but is useful when reused in pressure-vessel.
  * Add some missing precondition checks
  * Assert we are not setuid before looking at the environment
  * graphics: Add EGL and Vulkan ICD enumeration
  * Distinguish between the Steam installation (root) and data paths.
    We had previously mixed these up: it isn't particularly obvious since
    they are usually the same. See the documentation for details.

 -- Simon McVittie <smcv@collabora.com>  Thu, 26 Sep 2019 13:34:01 +0100

steam-runtime-tools (0.20190909.0-0+steamrt1.2) scout; urgency=medium

  [ Simon McVittie ]
  * Add checks for locales and locale-related issues

  [ Jeremy Whiting ]
  * When executing graphics helpers use timeout command to kill if needed.

  [ Simon McVittie ]
  * graphics: Add precondition checks on enum arguments
  * graphics: Diagnose impossible window system, rendering interface
  * graphics: Only allow EGL_X11 with a GL-based rendering interface
  * graphics: Diagnose combination of GLX with non-GL as programming error
  * Fix numeric values in comments
  * Document SRT_GRAPHICS_ISSUES_TIMEOUT
  * Improve diagnostics if graphics timeout tests fail

  [ Jeremy Whiting ]
  * Add calling vulkaninfo to get vulkan device and version.
  * Add mock-good-vulkaninfo and mock-bad-vulkaninfo.

  [ Simon McVittie ]
  * d/.gitignore: Update for addition of steam-runtime-tools-bin
  * Speed up tests by telling the graphics check to time out sooner
  * graphics: Don't free a const version_string
  * Add a man page documenting steam-runtime-system-info

 -- Jeremy Whiting <jeremy.whiting@collabora.com>  Mon, 09 Sep 2019 11:17:49 -0600

steam-runtime-tools (0.20190822.0-0+steamrt1.1) scout; urgency=medium

  [ Jeremy Whiting ]
  * Add SrtGraphics wrapper to check for GL, GLES support
  * Remove check-gl and check-gles since we changed to using wflinfo

  [ Simon McVittie ]
  * Minor bug fixes in SrtGraphics
  * helpers: Depend on waffle-utils-multiarch
  * CI: Add a build that uses clang, scan-build, ASan and UBSan

 -- Simon McVittie <smcv@collabora.com>  Thu, 22 Aug 2019 18:50:26 +0100

steam-runtime-tools (0.20190820.1-0+steamrt1.1) scout; urgency=medium

  * Fix version number in meson.build

 -- Simon McVittie <smcv@collabora.com>  Tue, 20 Aug 2019 19:25:55 +0100

steam-runtime-tools (0.20190820.0-0+steamrt1.1) scout; urgency=medium

  [ Simon McVittie ]
  * runtime: Avoid shadowing POSIX environ
  * runtime: Fix buffer underrun if version.txt is empty

  [ Ludovico de Nittis ]
  * fake-home: Fix memory leaks
  * Filter */gameoverlayrenderer.so from LD_PRELOAD

 -- Simon McVittie <smcv@collabora.com>  Tue, 20 Aug 2019 19:19:49 +0100

steam-runtime-tools (0.20190816.0-0+steamrt1.1) scout; urgency=medium

  [ Simon McVittie ]
  * inspect-library: Don't produce malformed JSON if the ABI is not known
  * library: Guard against not knowing missing or misversioned symbols
  * library: Set UNKNOWN_EXPECTATIONS issue if we lack a symbols file
  * bin: Check for shared libraries even if we don't know what to expect
  * system-info: Look for expectations in /usr/lib/steamrt by default
  * Add some mechanisms to facilitate design-for-test

  [ Ludovico de Nittis ]
  * Add checks for problems with the Steam Installation and the Runtime

 -- Simon McVittie <smcv@collabora.com>  Fri, 16 Aug 2019 12:38:22 +0100

steam-runtime-tools (0.20190806.0-0+steamrt1.1) scout; urgency=medium

  [ Ludovico de Nittis ]
  * Enhance examples/system-info.c to show libraries and uinput capabilities
  * Add C argument `-D_GNU_SOURCE` for the whole project

  [ Simon McVittie ]
  * system-info: Avoid g_debug() interfering with machine-readable stdout
  * system-info: Move from examples/ to bin/ and install in its own package

 -- Simon McVittie <smcv@collabora.com>  Tue, 06 Aug 2019 17:47:36 +0100

steam-runtime-tools (0.20190802.0-0+steamrt1.1) scout; urgency=medium

  [ Simon McVittie ]
  * SrtSystemInfo: Document (lack of) thread-safety
  * Improve documentation

  [ Ludovico de Nittis ]
  * Add libraries check to SrtSystemInfo

 -- Simon McVittie <smcv@collabora.com>  Fri, 02 Aug 2019 13:49:46 +0100

steam-runtime-tools (0.20190801.0-0+steamrt1.1) scout; urgency=medium

  [ Ludovico de Nittis ]
  * Add inspect-library helper and wrapper

  [ Simon McVittie ]
  * Add a skeleton for SrtLibrary, representing a shared library
  * Add symbolic constants for the i386 and x86_64 ABIs
  * Locate libsteam-runtime-tools with dladdr1(), not by iterating link map
  * _srt_get_helpers_path: Adjust mapping from ${libdir} to ${prefix}
  * Add a script to wrap tests with valgrind
  * Don't build gtk-doc documentation if gtk-doc is too old
  * Install enums.h below ${includedir} as intended
  * Add missing enums.h to <steam-runtime-tools/steam-runtime-tools.h>
  * build: Ensure that enums.[ch] are generated before compiling examples
  * _srt_get_helpers_path: If in /lib, assume helpers are in /usr/libexec
  * test-utils: Add some missing test assertions etc.
  * d/tests: Log debug messages
  * d/tests: Mark gnome-desktop-testing to be skipped if not installable
  * debian: Enable Gitlab-CI
  * utils: Ensure that g_type_init() gets called
  * build: Allow C99 constructs
  * build: Disable -Wunused-local-typedefs
  * inspect-library: Treat "-" as meaning stdin
  * inspect-library: Add simple command-line parsing
  * inspect-library: Make memory management more obvious
  * inspect-library: Reuse a buffer between iterations
  * inspect-library: Allow just a symbol on a line, with no @
  * inspect-library: Add support for consuming deb-symbols(5) files
  * Add a skeleton for SrtSystemInfo

 -- Simon McVittie <smcv@collabora.com>  Thu, 01 Aug 2019 18:54:13 +0100

steam-runtime-tools (0.20190717.0-0+collabora1) upstream; urgency=medium

  * Initial release

 -- Simon McVittie <smcv@collabora.com>  Wed, 17 Jul 2019 12:59:02 +0100